مشکلات امنیتی اسکریپت های آماده مانند جوملا

 چهارشنبه 26 فروردین 1394 - 11:08
 1
 3269
بدون امتیاز
مشکلات امنیتی اسکریپت های آماده مانند جوملا

مشکلات امنیتی اسکریپت های آماده مانند جوملا و لزوم بروزرسانی آنها جهت رفع این مشکلات اهمیت بسیار زیادی دارد. سال گذشته یک شرکت بین المللی در زمینه هاستینگ و ارائه سرور های اختصاصی در کانادا به تمام مشتریان خود اعلام کرد که در صورتی که از وردپرس نسخه پایینتر در سرورهای خود استفاده میکنند و آن را بروزرسانی نکرده اند سریعتر این اقدام را انجام دهند و در غیر اینصورت سرویس آنها قطع خواهد گردید.

وردپرس در سه نسخه پشت سر هم دارای مشکلات امنیتی بود که به هکر ها اجازه میداد تا بتوانند از طریق وب سایت شما ایمیل تبلیغاتی ارسال کنند و فایل آپلود کنند. اسکریپت های آماده و کد باز به دلیل میزان استفاده بالا (به دلیل رایگان بودن) از یک طرف و کدباز بودن از طرف دیگر جذابیت زیادی برای هکرهای تازه کار دارند و هکرها به راحتی میتوانند به آنها نفوذ کنند.

امروز یکی از شرکتهای هاست داخل ایران اطلاعیه ای برای بروزرسانی جوملا منتشر کرده است که آن را در اینجا می آورم :

کاربر گرامی
با سلام؛

نظر به افزایش اختلالات امنیتی بوجود آمده بر روی سایتهای ایجاد شده با سیستم های مدیریت محتوای رایگان و سایتهایی که از نرم افزارهای طراحی سایت رایگان استفاده نموده اند و با توجه به این نکته که مدیریت سایت یک فرآیند مداوم و ادامه دار بوده و عدم توجه به بروز رسانی و رفع موارد امنیتی، باعث ایجاد اختلال و اشکال بر روی سایت طراحی شده با این نرم افزارها و در نهایت کل سرور خواهد شد.

از این جهت ذیلا مواردی در این خصوص جهت استحضار اعلام میگردد.

در ارتباط با مدیریت محتوای جوملا (
Joomla)، ضعف و حفره های امنیتی موجود در نسخه های 2.5 و پایین تر این نرم افزار باعث کاهش امنیت و هک شدن سایت هایی که با این نسخه از نرم افزار طراحی شده اند، می گردد و در بعضی موارد این اختلالات امنیتی باعث بروز مشکلات شدیدی بر روی سرور میزبانی گردیده است. از این رو در جهت عدم وقوع مواردی از این دست و افزایش امنیت و بهبود امکانات سایت هایی که با این CMS طراحی شده اند، لطفا در اسرع وقت نسبت به روزرسانی این نرم افزار به نسخه های بالاتر اقدام نمائید، چرا که در صورت بروز مشکل و هک شدن سایت متاسفانه شرکت .... هیچگونه مسئولیتی را در این خصوص پذیرا نبوده و عواقب ناشی از آن متوجه مالکان و متصدیان سایت مذکور خواهد بود.
در این خصوص میتوانید جهت اطلاع از بولتن های خبری و نحوه اعمال تنظیمات امنیتی، از بخش
Security سایت رسمی Joomla به آدرس ذیل بهره گیرید.

http://developer.joomla.org/security.html

این موارد در ارتباط با
CMSهای رایگان دیگر ازجمله Wordpress، .NET Nuke، .... نیز صدق کرده و اعمال موارد امنیتی مربوطه می بایست از سمت طراحان و برنامه نویسان این سایتها نیز پیگیری و اجرا گردد.


بروزرسانی سیستم مدیریت محتوا همواره این اطمینان را به شما خواهد داد که مشکلات قبلی امنیتی و حفره های پیدا شده را نخواهید داشت و به همین جهت به تمام افرادی که از چنین سیستم هایی استفاده می کنند پیشنهاد میکنم که همواره سایت خود را به آخرین نسخه موجود ارتقا دهند تا مشکلات اینچنینی برایشان بوجود نیاید.
 

مطالب مرتبط
دیدگاه خود را با ما در میان بگذارید
امتیاز شما به این مقاله:





دیدگاه کاربران
reza
 ارسال شده در : چهارشنبه 26 فروردین 1394

صرفا بروز رسانی و رعایت نکات امنیتی در خصوص مدیریت محتوپای عمومی و قالب های خربوطه کافی است و این سیستم ها نسبت به مد77237یریت محتواهای اختصاصی طراحان سایت برتری های بیشماری دارند صرفا زمانی که سایت به یک سایت بزرگ تبدیل میشود بهتر است کم کم به فکر طراحی اختصاصی بود تا توجیح داشته باشد